Страницы

среда, 7 января 2015 г.

Node.js debugger is corrupted

На днях обнаружил одну неприятную особенность Node.js версий > 0.10.33, а именно косяк в отладчике. Для тех, кто дебажит по-стариковски через console.log это конечно ерунда, но я уже давно привык к node-inspector, поэтому пришлось откатиться на версию 0.10.33. Не интересно кто там накосячил - Joyent или Google, будем надеяться что в следующих версиях Node.js пофиксят это баг, да и вообще на мой взгляд пора бы уже 0.12 или 1.0 сбилдить, ECMAScript 6 можно не ждать.


А Вы как думаете?

Update: 09.01 обновил node-inspector до версии 0.8.1 после чего оказалось что этому инструменту предпочтительнее работать с Node.js версий >= 0.11.13:

Похоже Joyent пора бы уже что-то менять, пока публика не разбежалась на io.js и т.п.

Update #2: 26.01 наконец-то родили версию 0.10.36 в которой пофиксили этот баг, не прошло и года :).